Warning: Illegal string offset 'request_amazon'... issue

If you encounter an issue which looks like this:

install the plugin latest version and then go to Amazon Config/ Bug Fixes tab and click the "Fix Request Amazon Issue" button (make sure the drop-down is set on Yes also).